Tutorial - Unable to update using YUM - using CentOS Stream 8 and Almalinux 8 | Vevioz Developers

Tutorial Unable to update using YUM - using CentOS Stream 8 and Almalinux 8

DevOps

Linux Systems Engineer
Joined
Oct 18, 2019
Messages
214
Reaction score
22
Points
18
Location
Novosibirsk, Russia
Website
addons.vevioz.com
Offline
When I attempt to check for updates, I receive the following:
Code:
[lloyd@localhost ~]$ sudo yum check-update
Updating Subscription Management repositories.
Invalid configuration value: failovermethod=priority in /etc/yum.repos.d/epel.repo; Configuration: OptionBinding with id "failovermethod" does not exist
Invalid configuration value: failovermethod=priority in /etc/yum.repos.d/epel.repo; Configuration: OptionBinding with id "failovermethod" does not exist
Invalid configuration value: failovermethod=priority in /etc/yum.repos.d/epel.repo; Configuration: OptionBinding with id "failovermethod" does not exist
Invalid configuration value: failovermethod=priority in /etc/yum.repos.d/pgdg-redhat-all.repo; Configuration: OptionBinding with id "failovermethod" does not exist
Invalid configuration value: failovermethod=priority in /etc/yum.repos.d/pgdg-redhat-all.repo; Configuration: OptionBinding with id "failovermethod" does not exist
Invalid configuration value: failovermethod=priority in /etc/yum.repos.d/pgdg-redhat-all.repo; Configuration: OptionBinding with id "failovermethod" does not exist
Invalid configuration value: failovermethod=priority in /etc/yum.repos.d/pgdg-redhat-all.repo; Configuration: OptionBinding with id "failovermethod" does not exist
Invalid configuration value: failovermethod=priority in /etc/yum.repos.d/pgdg-redhat-all.repo; Configuration: OptionBinding with id "failovermethod" does not exist
Invalid configuration value: failovermethod=priority in /etc/yum.repos.d/pgdg-redhat-all.repo; Configuration: OptionBinding with id "failovermethod" does not exist
Invalid configuration value: failovermethod=priority in /etc/yum.repos.d/pgdg-redhat-all.repo; Configuration: OptionBinding with id "failovermethod" does not exist
Invalid configuration value: failovermethod=priority in /etc/yum.repos.d/pgdg-redhat-all.repo; Configuration: OptionBinding with id "failovermethod" does not exist
Invalid configuration value: failovermethod=priority in /etc/yum.repos.d/pgdg-redhat-all.repo; Configuration: OptionBinding with id "failovermethod" does not exist
Last metadata expiration check: 0:00:24 ago on Wed 29 Dec 2021 11:45:08 AM GMT.

Looks like the failover method is no longer supported for EL8 since it has been removed from DNF.
You can remove from the .repo files and try:
Code:
sudo sed -i '/^failovermethod=/d' /etc/yum.repos.d/*.repo
 
Top Bottom